9th April 2012 – First Race Report

YouTube Video: David Rose Castle Combe Saloons 9t April 2012

First race of the season for a change!! I’ve never done the first race and I’d never done a wet race either…was dry the day before but unfortunately the forecast was right and it rained all Monday!! I went out for qualifying on a set of Yokohama AD08’s and what a mistake that was, it was like I was driving on ice, no matter the speed I took a corner I was sideways which made things quite interesting. I qualified dead last with a time of 1:58:108 so I could only go forwards lol!!

After qualifying we noticed the front wheels were towing out for some reason so we lined them up a bit better by eye as I don’t have a toe gauge and I also managed to get a set of Toyo T1R’s brought from home (my old tyres) and got them fitted before the race. I got a good start and I moved up 8 cars in the first lap and another 3/4 on the second before Annie King span in front of me and my car seemed to copy lol!I managed to rejoin losing a few places and then on the way up Folly I had a good run alongside Paul Gardner but he didn’t know I was there and came across me so I lifted and that sent me into a slide (fastest part of the track on a slight bend is not where you want to lift lol!!). So I lost a few more positions however I soon moved back up a few places but coming towards the Esses the exhaust started blowing massively so I pulled in and was towed back at the end of the race. Had a look under the car and the exhaust manifold had broken where it joins the cat pipe, which is strange but so far I’m assuming I must have knocked it somewhere.

Progress has definitely been made and the car feels a lot faster with the new gearbox, I was up to 3rd in class before I span and subsequently stopped, which is a great result! So I’m very happy with the car and hopefully next time I’ll finish 🙂